Zum Inhalt springen

Archiv für Februar 2017

On Design Tools and Processes - Viljami Salminen

For the past year(s) I’ve been chasing for answers. Looking for new tools, thinking about design processes and figuring out what design really means to me. At times I’ve felt so disconnected with our pro­cesses that I’ve wondered if my career choice was right.
For a field rooted in the fine arts this period of change has been increasingly hard and is about to get even harder. We’ve moved away from designing static pages to creating digital systems of components, but we’ve done that mostly by using the same static design tools like Illustrator, Sketch, or even Figma. Tools

...

Accessibility, The Free Market, and Punching Nazis While Sitting Down – Heydon Pickering

By characterizing disability as a discrete ‘target’ group, the aim is to excuse the creation of products and services which do not cater for disability. “Oh I’m not making things for disabled people. But I’m sure someone else is, don’t worry. Such-and-such law of economics states it must be so.”

Disability does not work that way, though. It isn’t a discrete community or field of interest. It is complex, multifaceted and pervades all kinds of cultural identity through race, socio-economic level, gender identity, and faith. If you create an inaccessible product or service, you are almost guaranteed to be

...

Neulich in der Wetterau

Fake Muhs.

WordPress 4.7.2 Security Release

WordPress versions 4.7.1 and earlier are affected (…):
The user interface for assigning taxonomy terms in Press This is shown to users who do not have permissions to use it. (…)
WP_Query is vulnerable to a SQL injection (SQLi) when passing unsafe data. WordPress core is not directly vulnerable to this issue, but we’ve added hardening to prevent plugins and themes from accidentally causing a vulnerability. (…)
A cross-site scripting (XSS) vulnerability was discovered in the posts list table. (…)
An unauthenticated privilege escalation vulnerability was discovered in a REST API endpoint (…)
An additional serious vulnerability was fixed in this release and

...